You are here: Home / Change Java version used for Firefox under OpenSuse 11.4 and other versions

Change Java version used for Firefox under OpenSuse 11.4 and other versions

by Hawke Robinson last modified Oct 25, 2015 11:03 PM
Typically Open Suse cofnigures Firefox to use Open Java as the default java binary. However this doesn't work well for a number of sites, so you may find it necessary to install the Sun JRE and browser plugin...

After that, you need to change which is the default java binary to use. Simply run (may need to sudo or su as root): update-alternatives --config java <enter> Select from the list shown: There are 3 alternatives which provide `java'. Selection Alternative ----------------------------------------------- + 1 /usr/lib64/jvm/jre-1.6.0-openjdk/bin/java 2 /usr/lib64/jvm/jre-1.5.0-gcj/bin/java * 3 /usr/lib64/jvm/jre-1.6.0-sun/bin/java Press enter to keep the default[*], or type selection number: You will need to restart your web browser (and really consider logging out and back in, or even rebooting, if you have other apps using the openjdk binary. This applies to a number of versions of OpenSuse, at least 11.x, 11.1, 11.2, 11.3, and 11.4. It may also apply to other versions, but I have not verified that one way or another. Hope that helps.

Navigation