You are here: Home / USB Docking Bays, comparison of 3

USB Docking Bays, comparison of 3

by Hawke Robinson last modified Oct 09, 2015 11:21 PM
I have needed to find some sort of docking bay for my Alienware M11x R2. ...

There are not dedicated bays or port replicators available, but their "might" be some USB units that may work. Currently, I am testing out 3 units. 2 are from Kensington, and 1 from Targus. All were purchasable from the Dell.com site... /usr/local/lib/xorg/modules/drivers

These USB docking stations all need to provide video, keyboard, and mouse as a minimum. Networking is a bonus for some locations, but not required at others.

The three products tested were:

Kensington Universal Notebook Docking Station with VGA/DVI. Part #K33930, Model #M01066

Kensington Universal Notebook Docking Station with VGA/DVI and Ethernet. Part #K33926, Model #M01065

Targus USB 2.0 Laptop Docking Station with Video. Model No: ACP51USZ, Item # 52.

All three had stickers indicating "DisplayLink Certified".

These need to primarily support Linux, but of course may once in a while need to support Windows.

I tested with the Alienware M11x R2, with the following specifications:

OS: Suse Linux 11.4 x64, Windows ....

 

 

Also with the Dell XPS m1330n with the following specifications:

OS: Ubuntu 11.04 x64, Windows ....

 

And finally with the HP dv9..... with the following specifications:

OS: Suse Linux 11.2 ..., Windows ....

 

 

I first tested the Kensington without the Ethernet, using the builtin wifi in my laptop to maintain network connectivity on the Alienware m11x R2.

It easily detected the keyboard and mouse within seconds working. Setting up audio, it was detected but needed a little configuration. I loaded Yast > Hardware > Sound. It now listed in addition to the laptop's Intel sound card, a "USB Multimedia Audio Device" "Unconfigured". So I highlighted it, then clicked edit, and quick configure. Then made it primary card (I'm using SUMF and SCPM to have different hardware profiles btw). Then saved and closed the Sound Configuration tool. When I started up Amarok, it immediatley then played music through the KVM > IOGear > External speakers.

As expected, the video is the most challenging part...

One other wrinkle, is also testing out the IOGear 4-Port USB KVM Switch GCS634U. Since I'm using a wireless logitech keyboard it was a little glictchy getting it to switch consoles at first. I needed to setup the primary cabling to my primary system, and then using the FN+ Pause/Break keys, it acted the same as Scroll Lock.

Navigation